WindowsにTensorFlowをpipでインストールする

ようやく Windows も TensorFlow の公式サポートに追加されました。

チュートリアルに忠実に従えば、何の問題もなくインストールできますが、微妙なところではまったのでメモ。

スポンサーリンク

Pip installation on Anaconda

TensorFlow 公式リリースのパッケージは、公式の Python3 系もしくは Anaconda3 で利用可能です。

Python のバージョンは 3.5 に限ります。

エラー対応

tensorflow-0.12.1-cp35-cp35m-win_amd64.whl is not a supported wheel on this platform.

MSVCP140.DLL がないと動かないらしいですが、そのエラーではありません。

2016/01/05 現在、バージョン指定なしで仮想環境に Python3 系をインストールすると Python 3.6 がインストールされるため、TensorFlow が入りません。

同じところで引っかかった人が StackOverflow にもいたので、割と見逃しがちかもしれないですね。

スポンサーリンク

コメント・質問する